You can skip this in seconds

Click here to continue

BrickShooter Jr. 1.1

What's Required in Version 1.1 of BrickShooter Jr.

DirectX 8 or later

What's New in Version 1.1 of BrickShooter Jr.

Fixed compatibility issues with Windows Vista.

Look for Similar Items by Category

Feedback

Popular Downloads